Resolved
1 South Sea Islander Way, Maroochydore 4558 - Power Outage

Started
27 January 2023 at 4:29 AM
Status
Resolved after about 2 hours

Impact

Operational
Affected
Managed & Community Wi-Fi
QLD Managed & Community Wi-Fi
  • Resolved

    Power has been restored and services operational.

  • Investigating

    Energex have reported a power outage at this location. The next update is expected at around 4:30pm AEST.